Search

TOPIC: High Quality comment

High Quality comment 4 months 2 weeks ago #26

  • drjsgw
  • drjsgw's Avatar
  • Offline
  • Navegador Iniciado
  • Posts: 2
  • Karma: 0
Hi,
I do not know what the purpose of this comment from the Correctness Quality check means:

The incorrect expression "both X and Y" has not been found in the requirement

Is it necessary to report not finding an error? If it is then every non-error should be reported!

Simon
The administrator has disabled public write access.

High Quality comment 4 months 2 weeks ago #27

  • juan-llorens
  • juan-llorens's Avatar
  • Offline
  • Administrador
  • Posts: 1
  • Thank you received: 1
  • Karma: 0
Hi Simon:

In what context did you find the message?
Was it running RQA V15.1? As a result of a metric calculation?
Could you perhaps send a snapshot as image?

Regards

Juan
The administrator has disabled public write access.
The following user(s) said Thank You: drjsgw

High Quality comment 4 months 2 weeks ago #28

  • javier-fernandez
  • javier-fernandez's Avatar
  • Offline
  • Administrador
  • Posts: 52
  • Thank you received: 1
  • Karma: 0
Hi Simon!

(Notice that I changed the location of this topic to RQS Suite -> Quality Metrics -> Correctness )

This message is the result of the Correctness metric: "R16 Non Ambiguity - Conjunction "both X and Y" (Avoid)". Please note that this metric is a Pattern Matching parameterized metric, meaning that it is based on a Pattern. The objective of the metric is to detect the textual structure "both (something) and (something)", that should be avoided in specifications.

Hope you find this information useful.

Regards,
Javier
The administrator has disabled public write access.
The following user(s) said Thank You: drjsgw

High Quality comment 4 months 2 weeks ago #29

  • drjsgw
  • drjsgw's Avatar
  • Offline
  • Navegador Iniciado
  • Posts: 2
  • Karma: 0
Thanks - I have found the issue - there was a comment in the "Summary" field when "High" quality was measured. This has been removed and the problem solved.
Thanks for the replies
The administrator has disabled public write access.